Rename metadata llvm.loop.vectorize.unroll to llvm.loop.vectorize.interleave
tnowicki at apple.com
Fri Jul 18 16:08:32 PDT 2014
Thanks for working on this!
Looks like the llvm patch was accidentally overwritten by the clang patch.
On Jul 18, 2014, at 4:03 PM, Mark Heffernan <meheff at google.com> wrote:
> Here's the updated patches. llvm.loop.vectorize.interleave is now llvm.loop.interleave.count.
> On Fri, Jul 18, 2014 at 2:25 PM, Mark Heffernan <meheff at google.com> wrote:
> On Fri, Jul 18, 2014 at 2:11 PM, Tyler Nowicki <tnowicki at apple.com> wrote:
> Perhaps you could rename ‘loop.vectorize.unroll' to ‘loop.interleave.count'. That way in a future patch we could add ‘loop.interleave.enable'.
> What do you think?
> Sounds reasonable. Happy to change it to whatever is most appropriate.
> On Jul 18, 2014, at 1:51 PM, Hal Finkel <hfinkel at anl.gov> wrote:
> > Nadav, Arnold,
> > I think this makes sense. Do either of you object?
> > -Hal
> > ----- Original Message -----
> >> From: "Mark Heffernan" <meheff at google.com>
> >> To: llvm-commits at cs.uiuc.edu, "cfe-commits" <cfe-commits at cs.uiuc.edu>, "Hal Finkel" <hfinkel at anl.gov>, "Tyler
> >> Nowicki" <tnowicki at apple.com>
> >> Sent: Friday, July 18, 2014 3:44:00 PM
> >> Subject: Rename metadata llvm.loop.vectorize.unroll to llvm.loop.vectorize.interleave
> >> This patch rename metadata llvm.loop.vectorize.unroll to
> >> llvm.loop.vectorize.interleave to avoid confusion with the
> >> concatenation unroller metadata (llvm.loop.unroll). It fell out of a
> >> discussion on patch http://reviews.llvm.org/D4576 . On that patch
> >> there was some confusion about whether llvm.loop.vectorize.unroll
> >> controlled the traditional (concatenation) loop unroller. And IIRC
> >> this isn't the first time there has been this confusion. Renaming
> >> vectorize.unroll to vectorize.interleave also more closely matches
> >> the pragma which generates the metadata (#pragma clang loop
> >> interleave_count). There are still lots of uses of "unroll" within
> >> the code in function/variable names and comments. I have no
> >> intention of changing those.
> >> Mark
> > --
> > Hal Finkel
> > Assistant Computational Scientist
> > Leadership Computing Facility
> > Argonne National Laboratory
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-commits