[PATCH] Inline short function using lambda to improve readability.

kledzik at apple.com kledzik at apple.com
Thu Apr 3 18:33:16 PDT 2014


  lambdas are all the rage, but it is hard to say this change "improves readability".    The existing was ...erase...remove_if...AtomCoalesedAway...

  Maybe if SymbolTable had a method:

     bool coalescedAway(const ld::Atom *atom) { return replacement(atom) != atom; }

  then the lamda could be:

     [&](const Atom *atom) {
          return _symbolTable.coalescedAway(atom);
        }

http://llvm-reviews.chandlerc.com/D3286



More information about the llvm-commits mailing list