[PATCH] [XCore] Support functions returning more than 4 words.
Richard Osborne
richard at xmos.com
Thu Feb 27 06:06:57 PST 2014
Thanks, I've committed this with the changes you suggested in r202397
On 27/02/14 11:44, robert lytton wrote:
> LGTM
>
>
> ================
> Comment at: lib/Target/XCore/XCoreISelLowering.cpp:1092-1093
> @@ +1091,4 @@
> + if (VA.isRegLoc()) {
> + Chain = DAG.getCopyFromReg(Chain, dl, RVLocs[i].getLocReg(),
> + RVLocs[i].getValVT(), InFlag).getValue(1);
> + InFlag = Chain.getValue(2);
> ----------------
> Replacing RVLocs[i] with VA would improve readability.
>
> ================
> Comment at: lib/Target/XCore/XCoreMachineFunctionInfo.h:35-37
> @@ -34,3 +34,5 @@
> bool EHSpillSlotSet;
> + unsigned ReturnStackOffset;
> + bool ReturnStackOffsetSet;
> int EHSpillSlot[2];
> int VarArgsFrameIndex;
> ----------------
> Can you swap these lines around, to keep EHSpillSlotSet with EHSpillSlot[].
>
>
> http://llvm-reviews.chandlerc.com/D2889
>
> BRANCH
> multiple_returns
>
> ARCANIST PROJECT
> llvm
--
Richard Osborne | XMOS
http://www.xmos.com
More information about the llvm-commits
mailing list