[PATCH] Introduce line editor library.

Peter Collingbourne peter at pcc.me.uk
Fri Jan 31 15:54:56 PST 2014



================
Comment at: lib/LineEditor/LineEditor.cpp:36
@@ +35,3 @@
+LineEditor::ListCompleterConcept::complete(StringRef Buffer, size_t Pos) const {
+  CompletionAction CA;
+  std::vector<Completion> Comps = getCompletions(Buffer, Pos);
----------------
Manuel Klimek wrote:
> Peter Collingbourne wrote:
> > Manuel Klimek wrote:
> > > Perhaps "Action"? Completion seems to be clear from the context.
> > Well, you could have other actions associated with a line editor, like the action when a bound key is pressed or when a line is entered. So I think this name makes things clear.
> Oh, I didn't mean the class name, I mean the local variable name (basically s/CA/Action/). I think "Action" is in this context easier to understand than CA. I strongly oppose initializations unless they are very very commonly used (an example is SM used in clang; but even there it quickly becomes a problem if it's not consistent, which it is not ;)
Makes sense - renamed.


http://llvm-reviews.chandlerc.com/D2200

COMMIT
  http://llvm-reviews.chandlerc.com/rL200595



More information about the llvm-commits mailing list