[PATCH] Asan libraries on ARM should (for now) be called generically as "arm".
Alexey Samsonov
samsonov at google.com
Fri Jan 31 03:16:01 PST 2014
Please add a test to test/Driver/sanitizer-ld.c to verify the expected runtime name on ARM.
================
Comment at: lib/Driver/Tools.cpp:1726
@@ +1725,3 @@
+// Until ARM libraries are build separately, we have them all in one library
+static StringRef getArchName(const ToolChain &TC) {
+ if (TC.getArch() == llvm::Triple::arm)
----------------
Rename this to getArchNameForCompilerRTLib or some such.
http://llvm-reviews.chandlerc.com/D2665
More information about the llvm-commits
mailing list