[PATCH] ARM IAS: refactor unwind context
Logan Chien
tzuhsiang.chien at gmail.com
Sun Dec 29 07:50:26 PST 2013
================
Comment at: lib/Target/ARM/AsmParser/ARMAsmParser.cpp:126
@@ +125,3 @@
+
+ bool isValid() const { return FnStartLoc.isValid(); }
+ bool cantUnwind() const { return CantUnwindLoc.isValid(); }
----------------
I feel this function name does not reflect what is it doing. Maybe it will be a good idea to rename this to hasFnStart()?
================
Comment at: lib/Target/ARM/AsmParser/ARMAsmParser.cpp:8337
@@ -8301,3 +8336,3 @@
// Check the ordering of unwind directives
- if (!FnStartLoc.isValid()) {
+ if (!UC.isValid()) {
Error(L, ".fnstart must precede .fnend directive");
----------------
For example, this condition says !UC.isValid(), but we are only checking .fnstart.
http://llvm-reviews.chandlerc.com/D2486
More information about the llvm-commits
mailing list