[PATCH] disabled switching ARM modes in inline asm

Jim Grosbach grosbach at apple.com
Tue Dec 10 12:52:53 PST 2013



================
Comment at: include/llvm/MC/MCTargetAsmParser.h:101
@@ +100,3 @@
+  /// ParsingInlineGnuAsm - Are we parsing GAS-syntax inline assembly?
+  bool ParsingInlineGnuAsm;
+
----------------
Greg Fitzgerald wrote:
> Renato Golin wrote:
> > I don't understand why you need this...
> Because the name 'ParsingInlineAsm' was taken for MS-style assembly.
Wouldn't this problem apply no matter what the syntax of the inline asm was in the user's source code?

Seems the flag should be generalized to be an enumeration of asm kind. Something like, "enum InlineAsmKind { ASM_RAW, ASM_MSINLINE, ASM_GNUINLINE };" except with better names. The various predicate checks would be changed to reference that.


http://llvm-reviews.chandlerc.com/D2255



More information about the llvm-commits mailing list