[PATCH] [lld][mach-o] binary reader and writer
kledzik at apple.com
kledzik at apple.com
Mon Nov 4 17:29:34 PST 2013
================
Comment at: lib/ReaderWriter/PECOFF/PECOFFLinkingContext.cpp:145-152
@@ -144,10 +144,10 @@
for (;;) {
- auto it = _renamedSections.find(sectionName);
- if (it == _renamedSections.end())
+ auto pos = _renamedSections.find(sectionName);
+ if (pos == _renamedSections.end())
break;
- if (visited.count(it->second)) {
+ if (visited.count(pos->second)) {
diagnostics << "/merge:" << from << "=" << to << " makes a cycle";
return false;
}
- sectionName = it->second;
+ sectionName = pos->second;
visited.insert(sectionName);
----------------
This rename was to avoid a shadowed variable warning. I'll make this a separate commit.
http://llvm-reviews.chandlerc.com/D2101
More information about the llvm-commits
mailing list