[PATCH] Start fleshing out the Darwin driver

Nick Kledzik kledzik at apple.com
Wed Aug 28 17:46:33 PDT 2013


Joe,

These patches all look good.  Would you like me to commit them?  It may take a few days, as I have a bunch of other changes I am juggling.

-Nick

On Aug 27, 2013, at 9:54 PM, Joe Ranieri <joe at alacatialabs.com> wrote:
> On Sat, Aug 24, 2013 at 11:46 AM, Nick Kledzik <kledzik at apple.com> wrote:
>> 
>> Think of validateImpl() as a check for the whole MachOLinkingContext which could have been created programmatically instead of through the driver. If the current_version in that struct is not the default value and the output type is not a dylib, then validateImpl() should warn/error that current_version won't be used.
>> 
>> In the Driver, the first thing it checks for is the output type, so when you get to -current_version farther down in the source, you can check if the output type is not a dylib and if not issue a warning/error.
>> 
>> -Nick
> 
> Okay, here is a series of patches for you to review:
> * The first patch, darwin_packed_version.diff, eliminates
> PackedVersion and introduces a helper function to parse a version into
> an uint32_t. I did not add a helper function to go in reverse because
> there currently is no need.
> * The second patch, darwin_options2.diff, adds support for the six
> options in the original patch. I believe it takes into account the
> feedback given so far.
> * The third patch, darwin_help.diff, makes the -help option actually
> work without having to specify input files.
> 
> -- Joe Ranieri
> <darwin_packed_version.diff><darwin_options2.diff><darwin_help.diff>




More information about the llvm-commits mailing list