[PATCH] EABI Divmod, take #1

Renato Golin renato.golin at linaro.org
Thu Jul 11 04:03:58 PDT 2013


On 11 July 2013 07:41, Anton Korobeynikov <anton at korobeynikov.info> wrote:

> +  bool isTargetEABI() const {
> +    return TargetTriple.getEnvironment() == Triple::EABI;
> +  }
>
> Looks a bit misleading. After all - gnueabi is eabi as well, but with
> just some additional stuff... Maybe it's possible to change the name
> somehow?
>

Hi Anton,

It is confusing, but that's what comes from the triple when it's set as
"eabi" rather than any other "*eabi" triple, which is misleading.

I can change the name of the function to something like "isTargetAEABI()"
or "isTargetBareMetal()" and deal with the triple problems later. Does that
make sense? Do you have any preference?

cheers,
--renato
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20130711/ef3f7f46/attachment.html>


More information about the llvm-commits mailing list