[PATCH] [Object] Split the ELF interface into 3 parts.

Michael Spencer bigcheesegs at gmail.com
Tue Jun 25 15:02:54 PDT 2013


  Factoring it out would take a long time and adds little value. The only useful diff is between ELF.h and ELFObjectFile.h.


================
Comment at: include/llvm/Object/ELF.h:357
@@ -780,1 +356,3 @@
+        sec->sh_entsize,
+        (const char *)(base() + sec->sh_offset + sec->sh_size));
   }
----------------
Sean Silva wrote:
> It seems like you have a lot of cases of this pattern `(const char *)(base() + X))`. Could you factor that out into a member function?
I'd rather do it as a separate patch. The real problem is switching between const char * and const uint8_t *.


http://llvm-reviews.chandlerc.com/D1033



More information about the llvm-commits mailing list