[llvm-commits] [lld] r172512 - in /lld/trunk: include/lld/Core/range.h unittests/CMakeLists.txt unittests/RangeTest.cpp

Chandler Carruth chandlerc at google.com
Fri Mar 22 10:54:33 PDT 2013


On Fri, Mar 22, 2013 at 10:08 AM, John McCall <rjmccall at apple.com> wrote:

> Yeah, I think a range<T> that just pairs a begin and end iterator and lets
> you
> iterate over it with the C++11 for-range syntax would provide roughly 99%
> of
> the utility of the more general thing.
>
> Do you want to handle this, or should I just sketch out a range with zero
> bells
> and whistles and commit it?
>

I'd call it an iterator_range<T> to clarify that it's not a fully generic
range thing...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20130322/513c422a/attachment.html>


More information about the llvm-commits mailing list