[PATCH] Fix initialization-order bug in llvm::support::TimeValue

Chandler Carruth chandlerc at gmail.com
Tue Feb 19 00:38:51 PST 2013


  Looks good with a nit about naming...


================
Comment at: include/llvm/Support/TimeValue.h:364-365
@@ -363,1 +363,4 @@
+
+    static const SecondsType posix_zero_time_seconds_;
+    static const SecondsType win32_zero_time_seconds_;
   /// @}
----------------
While I know this code isn't very consistent about it, I would follow the standard LLVM naming convention for these variables.


http://llvm-reviews.chandlerc.com/D403

BRANCH
  svn

ARCANIST PROJECT
  llvm



More information about the llvm-commits mailing list