[llvm-commits] [RFC] Towards an assembler parser for PowerPC

Chris Lattner clattner at apple.com
Fri Jan 18 11:54:37 PST 2013


This is really great Ulrich, I'm glad you're pushing forward on it.

On Jan 18, 2013, at 10:06 AM, Ulrich Weigand <Ulrich.Weigand at de.ibm.com> wrote:
> Hal Finkel <hfinkel at anl.gov> wrote on 18.01.2013 18:52:29:
>> Can't you just mark the other definitions as CodeGenOnly? It is nice
>> to have the aliased memnoics in the assembly output -- it makes
>> things more readable (IMHO).
> 
> Agreed, when generating .s this should still use mnemonics.  One way
> might be to do it in PPCInstPrinter::printInst as is done e.g. for "mr".

Right.  All things being equal, it is better to have fewer instructions, and to just use one as the canonical (general) form.  Convenience aliases should be done with InstAlias, which the tblgen generated instprinter should pick up for free (at least in the simple/common cases).

-Chris




More information about the llvm-commits mailing list