[llvm-commits] [PATCH] Split AddressSanitizer into two passes (FunctionPass, ModulePass), LLVM part

Chandler Carruth chandlerc at gmail.com
Wed Nov 28 02:20:55 PST 2012


  This is also totally fine. =] I have some nits about the name, we can sort that out whenever.


================
Comment at: include/llvm/Transforms/Instrumentation.h:38
@@ -38,1 +37,3 @@
+FunctionPass *createAddressSanitizerFunctionPass();
+ModulePass *createAddressSanitizerModulePass();
 // Insert ThreadSanitizer (race detection) instrumentation
----------------
I might call this AddressSanitizerGlobalRedZonePass or even AddressSanitizerGlobalPass? Essentially, point out the reason why there are somethings that necessarily done in a separate (non-function) pass...


http://llvm-reviews.chandlerc.com/D137



More information about the llvm-commits mailing list