[llvm-commits] LLD: patch Program Headers
Michael Spencer
bigcheesegs at gmail.com
Tue Nov 13 12:23:40 PST 2012
On Tue, Nov 6, 2012 at 3:59 PM, Hemant Kulkarni <khemant at codeaurora.org> wrote:
> Attached is the patch with changes as per review comments.
>
> -Hemant
> + enum class chunkKind {
> + Header, // This is a header chunk
> + Section // chunk represents a section
> + };
This should be named Kind. It's already in the Chunk class.
> + static inline bool classof(const Chunk<target_endianness, is64Bits>*) {
> + return true;
> + }
These aren't needed anymore. See http://llvm-reviews.chandlerc.com/rL165767
> + static inline bool classof(const SectionChunk<target_endianness, is64Bits> *s) {
> + return true;
> + }
same. More of these further.
> + std::map<Elf_Sym*,const Atom*> _symbolToAtom;
Space after ,
Other than that is looks good. Fix and commit.
- Michael Spencer
More information about the llvm-commits
mailing list