[llvm-commits] MachOObjectFile fix functions
resistor at mac.com
Fri Nov 25 12:58:54 PST 2011
I'm good with this version. Go ahead and apply.
On Nov 24, 2011, at 12:05 PM, Danil Malyshev wrote:
> From: Danil Malyshev
> Sent: Saturday, November 12, 2011 3:00 AM
> To: 'Owen Anderson'
> Cc: 'llvm-commits at cs.uiuc.edu'
> Subject: RE: [llvm-commits] MachOObjectFile fix functions
> Hello Owen
> > I see your reasoning here, but it scares me a little bit to have methods with the same name that do different things.
> > I think we should either rename them to be obviously different, or pick a consistent meaning for all of them.
> I have renamed symbol.getOffset() as getFileOffset().
> Please find attached the changed patch.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-commits