[llvm-commits] [PATCH] Rename LLVM_MULTITHREADED define and fix build without threads

arrowdodger 6yearold at gmail.com
Sat Aug 6 03:21:23 PDT 2011


Hi, there is LLVM_MULTITHREADED define which is actually indicates presence
of atomic builtins in the host system. Such name may confuse developers in
future and already confused someone at lib/Support/Threading.cpp - he used
this define to check whether LLVM is built with threading support. This
mistake is currently blocking single-threaded build on Unix.

This patch do following things:
1. Rename LLVM_MULTITHREADED to LLVM_HAVE_ATOMICS in CMake checking code and
configure.ac, fix description of this option.
2. Replaces all uses of old define with new one.
3. Fix lib/Support/Threading.cpp file by using ENABLE_THREADS define instead
of LLVM_MULTITHREADED.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20110806/a26e6001/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: llvm.atomics.define.diff
Type: text/x-patch
Size: 6430 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20110806/a26e6001/attachment.bin>


More information about the llvm-commits mailing list