[llvm-commits] [PATCH] simplify various Instructions' resizeOperands() methods

Jay Foad jay.foad at gmail.com
Wed Mar 30 05:27:33 PDT 2011


Various Instructions have resizeOperands() methods. Since this patch:

http://lists.cs.uiuc.edu/pipermail/llvm-commits/Week-of-Mon-20110328/118717.html

... they are all only called with an argument of 0. Simplify them accordingly.

(Maybe resizeOperands() should be renamed now that it always just
grows the list of operands by some constant factor, but I couldn't
think of a good new name.)

Tested with "make check", LLVM and Clang. OK to apply?

Thanks,
Jay.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: simplify-resizeoperands.diff
Type: text/x-patch
Size: 5812 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20110330/cc90207d/attachment.bin>


More information about the llvm-commits mailing list