[llvm-commits] Patches to build EFI with clang/llvm

Evan Cheng evan.cheng at apple.com
Fri Jan 28 22:58:38 PST 2011


One more nitpick. Please rename isTargetMacho to something like isTargetEnvMacho(). isTargetDarwin() etc. are used to test OS type while Macho is an environment type.

Thanks,

Evan
On Jan 26, 2011, at 2:28 PM, Carl Norum wrote:

> 
> On Jan 26, 2011, at 2:17 PM, Carl Norum wrote:
>> I'll try to look at those suspicious conditionals that Jakob pointed out yesterday and see if I can clean them up.  As I mentioned before, I'm not that familiar with the code or the changes, but I'll see what I can do.
> 
> And here are some new patches.  I extended isTargetMacho() to return true for all Darwin targets, and that helped me clean up a bunch of the funny ones.  I think I have to leave the ones of the form:
> 
> 	if (Subtarget->isTargetCOFF() && !Subtarget->isTargetMacho())
> 
> Until isTargetCOFF() is implemented differently to not return true for all triples containing 'win32'.
> 
> Let me know what you think of these patches!
> 
> -- Carl
> 
> <macho-2.patch>_______________________________________________
> llvm-commits mailing list
> llvm-commits at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits





More information about the llvm-commits mailing list