[llvm-commits] [llvm] r121444 - /llvm/trunk/docs/CodingStandards.html
Chris Lattner
sabre at nondot.org
Thu Dec 9 16:54:04 PST 2010
Author: lattner
Date: Thu Dec 9 18:54:03 2010
New Revision: 121444
URL: http://llvm.org/viewvc/llvm-project?rev=121444&view=rev
Log:
fix some validation problems
Modified:
llvm/trunk/docs/CodingStandards.html
Modified: llvm/trunk/docs/CodingStandards.html
URL: http://llvm.org/viewvc/llvm-project/llvm/trunk/docs/CodingStandards.html?rev=121444&r1=121443&r2=121444&view=diff
==============================================================================
--- llvm/trunk/docs/CodingStandards.html (original)
+++ llvm/trunk/docs/CodingStandards.html Thu Dec 9 18:54:03 2010
@@ -60,7 +60,7 @@
loop</a></li>
<li><a href="#ll_iostream"><tt>#include <iostream></tt> is
<em>forbidden</em></a></li>
- <li><a href="#ll_raw_ostream">Use <tt>raw_ostream</tt></a</li>
+ <li><a href="#ll_raw_ostream">Use <tt>raw_ostream</tt></a></li>
<li><a href="#ll_avoidendl">Avoid <tt>std::endl</tt></a></li>
</ol></li>
@@ -828,24 +828,25 @@
</p>
<ul>
-<li><b>Type names</b> (including classes, structs, enums, typedefs, etc) should
- be nouns and start with an upper-case letter (e.g. <tt>TextFileReader</tt>).
+<li><p><b>Type names</b> (including classes, structs, enums, typedefs, etc)
+ should be nouns and start with an upper-case letter (e.g.
+ <tt>TextFileReader</tt>).</p>
</li>
-<li><b>Function names</b> should be verb phrases (as they represent
+<li><p><b>Function names</b> should be verb phrases (as they represent
actions), and command-like function should be imperative. The name should
be camel case, and start with a lower case letter (e.g. <tt>openFile()</tt>
- or <tt>isFoo()</tt>).
+ or <tt>isFoo()</tt>).</p>
</li>
-<li><b>Enum declarations</b> (e.g. "enum Foo {...}") are types, so they should
- follow the naming conventions for types. A common use for enums is as a
+<li><p><b>Enum declarations</b> (e.g. "enum Foo {...}") are types, so they
+should follow the naming conventions for types. A common use for enums is as a
discriminator for a union, or an indicator of a subclass. When an enum is
used for something like this, it should have a "Kind" suffix (e.g.
- "ValueKind").
+ "ValueKind").</p>
</li>
-<li><b>Enumerators</b> (e.g. enum { Foo, Bar }) and
+<li><p><b>Enumerators</b> (e.g. enum { Foo, Bar }) and
<b>public member variables</b> should start with an upper-case letter, just
like types. Unless the enumerators are defined in their own small
namespace or inside a class, enumerators should have a prefix corresponding
More information about the llvm-commits
mailing list