[llvm-commits] [PATCH] Bug 5207: make APInt set(), clear() and flip() return void
Jay Foad
jay.foad at gmail.com
Tue Nov 30 07:14:44 PST 2010
On 30 November 2010 09:04, Jay Foad <jay.foad at gmail.com> wrote:
>> Looks great to me, please commit. I'd also suggest renaming the methods to "setAllBits()" "clearAllBits" "flipAllBits" etc. Thanks for working on this Jay!
> The methods are overloaded. We have:
>
> void set(); // set all bits
> void set(unsigned); // set a single bit
>
> ... and likewise for clear() and flip(). So maybe rename them to
> setAllBits() and setBit(unsigned) respectively?
Patch attached. It passes "make check". Do you like?
Jay.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: setallbits.diff
Type: text/x-patch
Size: 19021 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20101130/9f2f1b4d/attachment.bin>
More information about the llvm-commits
mailing list