[llvm-commits] [llvm] r115611 - /llvm/trunk/test/CodeGen/X86/atomic_op.ll
NAKAMURA Takumi
geek4civic at gmail.com
Tue Oct 5 04:16:24 PDT 2010
Author: chapuni
Date: Tue Oct 5 06:16:24 2010
New Revision: 115611
URL: http://llvm.org/viewvc/llvm-project?rev=115611&view=rev
Log:
test/CodeGen/X86/atomic_op.ll: Rename @main to @func. Extra sequences will be inserted to @main as prologue on cygming, to fail.
Modified:
llvm/trunk/test/CodeGen/X86/atomic_op.ll
Modified: llvm/trunk/test/CodeGen/X86/atomic_op.ll
URL: http://llvm.org/viewvc/llvm-project/llvm/trunk/test/CodeGen/X86/atomic_op.ll?rev=115611&r1=115610&r2=115611&view=diff
==============================================================================
--- llvm/trunk/test/CodeGen/X86/atomic_op.ll (original)
+++ llvm/trunk/test/CodeGen/X86/atomic_op.ll Tue Oct 5 06:16:24 2010
@@ -2,7 +2,7 @@
target datalayout = "e-p:32:32:32-i1:8:8-i8:8:8-i16:16:16-i32:32:32-i64:32:64-f32:32:32-f64:32:64-v64:64:64-v128:128:128-a0:0:64-f80:128:128"
-define void @main(i32 %argc, i8** %argv) nounwind {
+define void @func(i32 %argc, i8** %argv) nounwind {
entry:
%argc.addr = alloca i32 ; <i32*> [#uses=1]
%argv.addr = alloca i8** ; <i8***> [#uses=1]
More information about the llvm-commits
mailing list