[llvm-commits] [llvm] r92216 - in /llvm/trunk: include/llvm/Metadata.h lib/VMCore/Metadata.cpp
sabre at nondot.org
Mon Dec 28 01:30:22 PST 2009
On Dec 28, 2009, at 1:26 AM, Nick Lewycky wrote:
> Chris Lattner wrote:
>> Author: lattner
>> Date: Mon Dec 28 02:48:12 2009
>> New Revision: 92216
>> URL: http://llvm.org/viewvc/llvm-project?rev=92216&view=rev
>> rename MDNode instance variables to something meaningful.
> Please name them Elements instead of Operands. There's a lot of great invariants that apply to operands which don't exist on MDNode elements.
I don't really care either way, anything is better than 'node'. We do have null operands though, e.g. global variable initializers, so I don't see how elements (which sounds like struct element to me) is better than operands here. We generally use 'element' for types, not values.
More information about the llvm-commits