[llvm-commits] [PATCH] Move stub allocation to the JITEmitter
Eric Christopher
echristo at apple.com
Tue Nov 17 14:23:58 PST 2009
On Nov 16, 2009, at 4:07 PM, Jeffrey Yasskin wrote:
> I've updated the patch to ToT at
> http://codereview.appspot.com/download/issue153044_2015.diff.
Few comments:
+ struct StubLayout {
+ size_t Size;
+ size_t Alignment;
+ };
Comment above it giving whether it's in bytes, bits, etc?
+TargetJITInfo::StubLayout PPCJITInfo::getStubLayout() {
+ StubLayout Result = {10*4, 1};
+ return Result;
+}
These could also use a block comment of the stub layout.
I hate magic numbers. Not your fault that we have so many though :)
+ /// for external functions. TODO(jyasskin): Of course, external functions
I think todos are for the readme file though you can reference that in your comment. Probably don't need your name though.
Otherwise it looks fine, I'll run it through tests here real fast.
-eric
More information about the llvm-commits
mailing list