[llvm-commits] Uninitialized EH DWARF in the JIT

Reid Kleckner rnk at mit.edu
Fri Aug 21 10:44:08 PDT 2009


> This makes emitAlignment dead then, right? Why not change emitAlignment to
> write the nops, and not take an extra parameter?

No, the JITEmitter uses it for aligning the constant pool, and
MachineCodeEmitters could potentially use it in other ways that don't
actually require that the memory be initialized.  The question is, if
we don't think it matters, should they be initialized to garbage, or
to zeros?  I'd prefer uninitialized in release mode, and garbage in
debug mode, which is what this patch implements.

> Also, don't reimplement RoundUpToAlignment() as AlignPtr().

Such a thing exists?  Awesome.  There's some serious proliferation of
this little alignment bithack, and it involves these ugly casts to
uintptr_t that are hard to read.

Reid
-------------- next part --------------
A non-text attachment was scrubbed...
Name: jit-eh-patch.diff
Type: text/x-patch
Size: 5282 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20090821/03183dc7/attachment.bin>


More information about the llvm-commits mailing list