[llvm-commits] [llvm] r74440 - in /llvm/trunk: include/llvm/MC/MCValue.h lib/MC/MCAsmStreamer.cpp

Daniel Dunbar daniel at zuster.org
Tue Jun 30 23:59:10 PDT 2009


On Tue, Jun 30, 2009 at 11:27 PM, Chris Lattner<clattner at apple.com> wrote:
> On Jun 29, 2009, at 12:51 PM, Daniel Dunbar wrote:
>>
>> Author: ddunbar
>> Date: Mon Jun 29 14:51:00 2009
>> New Revision: 74440
>>
>> URL: http://llvm.org/viewvc/llvm-project?rev=74440&view=rev
>> Log:
>> Rename MCValue::getCst to getConstant and add MCValue::isConstant.
>
> Ok,
>
>> +  int64_t getConstant() const { return Cst; }
>>  MCSymbol *getSymA() const { return SymA; }
>>  MCSymbol *getSymB() const { return SymB; }
>> +
>> +  bool isConstant() const { return !SymA && !SymB; }
>
> Please rename isConstant() to isAbsolute() or something like that.
>  Otherwise it sounds like isConstant() -> true is the only way the Cst field
> would make sense.  Do you agree?

Yes, fixed.

 - Daniel




More information about the llvm-commits mailing list