[llvm-commits] [llvm] r71588 - in /llvm/trunk/lib/CodeGen: PEI.h PrologEpilogInserter.cpp ShrinkWrapping.cpp
ojomojo at gmail.com
Tue May 12 15:04:17 PDT 2009
On Tue, May 12, 2009 at 3:32 PM, Evan Cheng <evan.cheng at apple.com> wrote:
> Thanks John. But the refactoring seems a bit strange to me.
> First of all, the convention is for the .h name to match the .cpp one.
> So perhaps PEI.h should be PrologueEpilogueInserter.h?
Of course, I'll rename it, sorry about that.
> As for the
> shrink wrapper, it doesn't have to be a separate pass, but can it be a
> separate class? Are there too much sharing of information between the
> two that the data passing overhead would be too high?
A separate class will be better, there are only two maps that are shared.
I'll put the shrink wrapping code into its own class.
Thanks for the feedback!
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-commits