[llvm-commits] DebugInfoBuilder

Talin viridia at gmail.com
Mon Aug 18 16:01:49 PDT 2008


I don't have a problem with changing the method names. The reason I used
upper case is because I thought that's what the convention was (the LLVM
sources aren't exactly consistent on this point, although there's been
considerable improvement since I first wrote this module.)

Do you want me to submit another patch, or can you just modify the names?

On Mon, Aug 18, 2008 at 1:26 PM, Anton Korobeynikov <anton at korobeynikov.info
> wrote:

>
> > Sorry about the delay in reviewing the patch. I have been away. I
> > think this looks good. Anton, what do you say?
> Oh, I'm sorry, I thought I answered to this e-mail.
>
> Overall patch looks ok for me. But I'd strongly suggest to change the
> names again to be consistent with usual LLVM naming:
>
> +    // Create an anchor with the specified tag.
> +    GlobalVariable * CreateAnchor(unsigned anchorTag, const char *
> anchorName);
> +
> +    // Calculate alignement for primitive types.
> +    unsigned GetBasicAlignment(unsigned sizeInBits);
> +
> +    // Calculate the size of the specified LLVM type.
> +    Constant * getSize(const Type * type);
> +
> +    // Calculate the alignment of the specified LLVM type.
> +    Constant * getAlignment(const Type * type);
> CreateAnchor => createAnchor, GetBasicAlignment => getBasicAlignment,
> etc.
>
> --
> With best regards, Anton Korobeynikov.
>
> Faculty of Mathematics & Mechanics, Saint Petersburg State University.
>
>


-- 
-- Talin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20080818/291bd7e2/attachment.html>


More information about the llvm-commits mailing list