[llvm-commits] [llvm-gcc-4.2] r49170 - in /llvm-gcc-4.2/trunk/gcc: llvm-abi.h llvm-convert.cpp llvm-types.cpp
Duncan Sands
baldrick at free.fr
Fri Apr 4 02:46:51 PDT 2008
Hi Devang, thanks for fixing this.
> -static bool isAggregateFunctionParam(tree type) {
> +static bool isAggregateFunctionParam(tree type, tree fndecl) {
Since this may not be the function declaration, how about calling
it "callee" rather than "fndecl"?
> - void HandleReturnType(tree type, bool isBuiltin) {
> + void HandleReturnType(tree type, tree fn, bool isBuiltin) {
Likewise I suggest "fn" -> "callee".
Ciao,
Duncan.
More information about the llvm-commits
mailing list