[llvm-commits] [llvm] r47802 - in /llvm/trunk: include/llvm/BasicBlock.h include/llvm/Bitcode/LLVMBitCodes.h lib/AsmParser/LLLexer.cpp lib/AsmParser/llvmAsmParser.y lib/Bitcode/Reader/BitcodeReader.cpp lib/Bitcode/Writer/BitcodeWriter.cpp lib/VMCore/AsmWriter.cpp lib/VMCore/BasicBlock.cpp test/Feature/unwindto.ll tools/llvm-bcanalyzer/llvm-bcanalyzer.cpp

Nick Lewycky nicholas at mxc.ca
Sun Mar 9 12:49:45 PDT 2008


Duncan Sands wrote:
>>> entry: unwinds %target
>>>
>>> I don't much like the underscore...
>> We've gone over a few options. If anyone feels strongly over it I'll be 
>> happy to make the change, but "unwinds" in particular is a mere typo 
>> away from the 'unwind' instruction.
> 
> yes, it is one letter away, but does it matter?  If you make the typo in
> either direction (unwind -> unwinds, or unwinds -> unwind) then it looks
> to me like it won't assemble, which is good: mistakes are caught.  It would
> be a problem if the result of the typo was silently accepted.

It's more of a "learning LLVM syntax" problem than a compiler problem.

How about:

   entry: unwinds to %target

if we're up for adding 'unwinds' as a keyword? It won't be ambiguous 
with anything so we can drop the underscore. Sound reasonable?

Nick




More information about the llvm-commits mailing list