[llvm-commits] CVS: llvm/include/llvm/Constants.h

Zhou Sheng zhousheng00 at gmail.com
Thu Mar 29 21:31:18 PDT 2007


在 2007-03-29四的 21:02 -0700,Chris Lattner写道:
> > +  /// This function will return true iff this constant represents  
> > a value with
> > +  /// active bits bigger than 64 bits or a value greater than the  
> > given uint64_t
> > +  /// value.
> > +  /// @returns true iff this constant is greater or equal to the  
> > given number.
> > +  /// @brief Determine if the value is greater or equal to the  
> > given number.
> > +  bool greaterOrEqual(uint64_t Num) {
> > +    return Val.getActiveBits() > 64 || Val.getZExtValue() > Num;
> 
> Shouldn't the second one be >= ?
Yes, i'll correct that.


> 
> Can you please rename this greaterOrEqualUnsigned  or even compare_gtu 
> (N)?
How about "bool compare_uge(uint64_t Num)" ?


> 
> 




More information about the llvm-commits mailing list