[llvm-commits] CVS: llvm/include/llvm/Constants.h
Chris Lattner
clattner at apple.com
Thu Mar 29 21:02:05 PDT 2007
> + /// This function will return true iff this constant represents
> a value with
> + /// active bits bigger than 64 bits or a value greater than the
> given uint64_t
> + /// value.
> + /// @returns true iff this constant is greater or equal to the
> given number.
> + /// @brief Determine if the value is greater or equal to the
> given number.
> + bool greaterOrEqual(uint64_t Num) {
> + return Val.getActiveBits() > 64 || Val.getZExtValue() > Num;
Shouldn't the second one be >= ?
Can you please rename this greaterOrEqualUnsigned or even compare_gtu
(N)?
More information about the llvm-commits
mailing list