[llvm-commits] CVS: llvm/lib/Transforms/Utils/SimplifyCFG.cpp
Chris Lattner
sabre at nondot.org
Sun Jan 14 18:28:16 PST 2007
Changes in directory llvm/lib/Transforms/Utils:
SimplifyCFG.cpp updated: 1.112 -> 1.113
---
Log message:
rename Type::isIntegral to Type::isInteger, eliminating the old Type::isInteger.
rename Type::getIntegralTypeMask to Type::getIntegerTypeMask.
This makes naming much more consistent. For example, there are now no longer any
instances of IntegerType that are not considered isInteger! :)
---
Diffs of the changes: (+1 -1)
SimplifyCFG.cpp | 2 +-
1 files changed, 1 insertion(+), 1 deletion(-)
Index: llvm/lib/Transforms/Utils/SimplifyCFG.cpp
diff -u llvm/lib/Transforms/Utils/SimplifyCFG.cpp:1.112 llvm/lib/Transforms/Utils/SimplifyCFG.cpp:1.113
--- llvm/lib/Transforms/Utils/SimplifyCFG.cpp:1.112 Sun Jan 14 19:55:30 2007
+++ llvm/lib/Transforms/Utils/SimplifyCFG.cpp Sun Jan 14 20:27:26 2007
@@ -1852,7 +1852,7 @@
Value *CompVal = 0;
std::vector<ConstantInt*> Values;
bool TrueWhenEqual = GatherValueComparisons(Cond, CompVal, Values);
- if (CompVal && CompVal->getType()->isIntegral()) {
+ if (CompVal && CompVal->getType()->isInteger()) {
// There might be duplicate constants in the list, which the switch
// instruction can't handle, remove them now.
std::sort(Values.begin(), Values.end(), ConstantIntOrdering());
More information about the llvm-commits
mailing list