[llvm-commits] CVS: llvm/lib/Target/X86/X86TargetAsmInfo.cpp
Chris Lattner
sabre at nondot.org
Sun Jan 14 18:28:14 PST 2007
Changes in directory llvm/lib/Target/X86:
X86TargetAsmInfo.cpp updated: 1.24 -> 1.25
---
Log message:
rename Type::isIntegral to Type::isInteger, eliminating the old Type::isInteger.
rename Type::getIntegralTypeMask to Type::getIntegerTypeMask.
This makes naming much more consistent. For example, there are now no longer any
instances of IntegerType that are not considered isInteger! :)
---
Diffs of the changes: (+1 -1)
X86TargetAsmInfo.cpp | 2 +-
1 files changed, 1 insertion(+), 1 deletion(-)
Index: llvm/lib/Target/X86/X86TargetAsmInfo.cpp
diff -u llvm/lib/Target/X86/X86TargetAsmInfo.cpp:1.24 llvm/lib/Target/X86/X86TargetAsmInfo.cpp:1.25
--- llvm/lib/Target/X86/X86TargetAsmInfo.cpp:1.24 Sun Jan 14 19:48:11 2007
+++ llvm/lib/Target/X86/X86TargetAsmInfo.cpp Sun Jan 14 20:27:26 2007
@@ -174,7 +174,7 @@
// Verify this is a simple bswap.
if (CI->getNumOperands() != 2 ||
CI->getType() != CI->getOperand(1)->getType() ||
- !CI->getType()->isIntegral())
+ !CI->getType()->isInteger())
return false;
const Type *Ty = CI->getType();
More information about the llvm-commits
mailing list