[llvm-commits] CVS: llvm/include/llvm/CodeGen/MachOWriter.h

Chris Lattner sabre at nondot.org
Sun Jan 14 18:28:16 PST 2007



Changes in directory llvm/include/llvm/CodeGen:

MachOWriter.h updated: 1.10 -> 1.11
---
Log message:

rename Type::isIntegral to Type::isInteger, eliminating the old Type::isInteger.
rename Type::getIntegralTypeMask to Type::getIntegerTypeMask.

This makes naming much more consistent.  For example, there are now no longer any
instances of IntegerType that are not considered isInteger! :)



---
Diffs of the changes:  (+1 -1)

 MachOWriter.h |    2 +-
 1 files changed, 1 insertion(+), 1 deletion(-)


Index: llvm/include/llvm/CodeGen/MachOWriter.h
diff -u llvm/include/llvm/CodeGen/MachOWriter.h:1.10 llvm/include/llvm/CodeGen/MachOWriter.h:1.11
--- llvm/include/llvm/CodeGen/MachOWriter.h:1.10	Sun Jan 14 15:46:42 2007
+++ llvm/include/llvm/CodeGen/MachOWriter.h	Sun Jan 14 20:27:26 2007
@@ -534,7 +534,7 @@
     }
     MachOSection *getConstSection(const Type *Ty) {
       // FIXME: support cstring literals and pointer literal
-      if (Ty->isPrimitiveType() || Ty->isIntegral()) {
+      if (Ty->isPrimitiveType() || Ty->isInteger()) {
         unsigned Size = TM.getTargetData()->getTypeSize(Ty);
         switch(Size) {
         default: break; // Fall through to __TEXT,__const






More information about the llvm-commits mailing list