[llvm-commits] CVS: llvm/lib/CodeGen/InstrSelection/InstrSelectionSupport.cpp
Alkis Evlogimenos
alkis at cs.uiuc.edu
Sun Dec 14 07:25:44 PST 2003
Changes in directory llvm/lib/CodeGen/InstrSelection:
InstrSelectionSupport.cpp updated: 1.59 -> 1.60
---
Log message:
Change interface of MachineOperand as follows:
a) remove opIsUse(), opIsDefOnly(), opIsDefAndUse()
b) add isUse(), isDef()
c) rename opHiBits32() to isHiBits32(),
opLoBits32() to isLoBits32(),
opHiBits64() to isHiBits64(),
opLoBits64() to isLoBits64().
This results to much more readable code, for example compare
"op.opIsDef() || op.opIsDefAndUse()" to "op.isDef()" a pattern used
very often in the code.
---
Diffs of the changes: (+2 -2)
Index: llvm/lib/CodeGen/InstrSelection/InstrSelectionSupport.cpp
diff -u llvm/lib/CodeGen/InstrSelection/InstrSelectionSupport.cpp:1.59 llvm/lib/CodeGen/InstrSelection/InstrSelectionSupport.cpp:1.60
--- llvm/lib/CodeGen/InstrSelection/InstrSelectionSupport.cpp:1.59 Wed Dec 10 16:51:41 2003
+++ llvm/lib/CodeGen/InstrSelection/InstrSelectionSupport.cpp Sun Dec 14 07:24:16 2003
@@ -178,8 +178,8 @@
// Bit-selection flags indicate an instruction that is extracting
// bits from its operand so ignore this even if it is a big constant.
- if (mop.opHiBits32() || mop.opLoBits32() ||
- mop.opHiBits64() || mop.opLoBits64())
+ if (mop.isHiBits32() || mop.isLoBits32() ||
+ mop.isHiBits64() || mop.isLoBits64())
continue;
opType = ChooseRegOrImmed(mop.getImmedValue(), isSigned,
More information about the llvm-commits
mailing list