[llvm-commits] CVS: llvm/include/llvm/Target/MachineInstrInfo.h
Chris Lattner
lattner at cs.uiuc.edu
Tue Oct 29 11:36:01 PST 2002
Changes in directory llvm/include/llvm/Target:
MachineInstrInfo.h updated: 1.30 -> 1.31
---
Log message:
Rename opCodeString to Name, add new getName() method
---
Diffs of the changes:
Index: llvm/include/llvm/Target/MachineInstrInfo.h
diff -u llvm/include/llvm/Target/MachineInstrInfo.h:1.30 llvm/include/llvm/Target/MachineInstrInfo.h:1.31
--- llvm/include/llvm/Target/MachineInstrInfo.h:1.30 Tue Oct 29 11:26:26 2002
+++ llvm/include/llvm/Target/MachineInstrInfo.h Tue Oct 29 11:35:09 2002
@@ -67,7 +67,7 @@
struct MachineInstrDescriptor {
- const char * opCodeString; // Assembly language mnemonic for the opcode.
+ const char * Name; // Assembly language mnemonic for the opcode.
int numOperands; // Number of args; -1 if variable #args
int resultPos; // Position of the result; -1 if no result
unsigned maxImmedConst; // Largest +ve constant in IMMMED field or 0.
@@ -101,6 +101,10 @@
const MachineInstrDescriptor& get(MachineOpCode opCode) const {
assert(opCode >= 0 && opCode < (int)descSize);
return desc[opCode];
+ }
+
+ const char *getName(MachineOpCode opCode) const {
+ return get(opCode).Name;
}
int getNumOperands(MachineOpCode opCode) const {
More information about the llvm-commits
mailing list