[llvm-bugs] [Bug 39166] New: Better error messages when ptrace() fails on linux

via llvm-bugs llvm-bugs at lists.llvm.org
Wed Oct 3 10:08:04 PDT 2018


            Bug ID: 39166
           Summary: Better error messages when ptrace() fails on linux
           Product: lldb
           Version: 7.0
          Hardware: PC
                OS: All
            Status: NEW
          Severity: enhancement
          Priority: P
         Component: All Bugs
          Assignee: lldb-dev at lists.llvm.org
          Reporter: davide at freebsd.org
                CC: llvm-bugs at lists.llvm.org

I was debugging a Linux lldb bug (on Linux).
I run linux in a VM using parallels, and for some reason lldb wasn't able to
attach to the inferior. The error message was:

"could not attach".

After a bit of scratching my head, I tried to run under gdb and I got the

"Could not attach to process. If your kid matches the kid of the target
process, check the setting of /proc/sys/kerne/yama/ptrace_scope, or try again
as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf.
ptrace: operation not permitted"

Which is much more informative. We might consider emitting better diagnostics
in this case (and similar ones). This is also a good beginner bug for somebody
who wants to get their feet wet and learn lldb.

You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-bugs/attachments/20181003/637194b5/attachment.html>

More information about the llvm-bugs mailing list