[llvm-bugs] [Bug 39524] New: Replace lli with %lli in RUN lines

via llvm-bugs llvm-bugs at lists.llvm.org
Thu Nov 1 15:40:15 PDT 2018


https://bugs.llvm.org/show_bug.cgi?id=39524

            Bug ID: 39524
           Summary: Replace lli with %lli in RUN lines
           Product: Test Suite
           Version: trunk
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: enhancement
          Priority: P
         Component: lit
          Assignee: unassignedbugs at nondot.org
          Reporter: eush77 at gmail.com
                CC: daniel at zuster.org, llvm-bugs at lists.llvm.org

Created attachment 21063
  --> https://bugs.llvm.org/attachment.cgi?id=21063&action=edit
WIP patch for converting all tests to %lli

`lit.cfg.py` defines substitutions for both `lli` and `%lli`, and this is
confusing, especially since there is no actual difference between these two
except that on Windows `%lli` includes an `-mtriple=' flag force-setting ELF
object format.

There is even a FIXME in `test/lit.cfg.py' about this very thing:

> # FIXME: Why do we have both `lli` and `%lli` that do slightly different
> things?

It seems like the majority of tests could be converted to use one or the other.
If all tests can be converted to one substitution, the other one should be
removed.
If there is a minority of tests that depend on the other substitution,
that substitution should be renamed to something special a la `%llc_dwarf` to
clearly indicate that it is a special case and not the default.

I included a patch that converts everything to `%lli`, but I don't know if it
really works because I don't have a Windows machine to test it on.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-bugs/attachments/20181101/ebf17b17/attachment.html>


More information about the llvm-bugs mailing list