[llvm-bugs] [Bug 40014] New: __lzcnt32() should be __lzcnt() in lzcntintrin.h

via llvm-bugs llvm-bugs at lists.llvm.org
Thu Dec 13 13:13:18 PST 2018


            Bug ID: 40014
           Summary: __lzcnt32() should be __lzcnt() in lzcntintrin.h
           Product: clang
           Version: 7.0
          Hardware: PC
                OS: Windows NT
            Status: NEW
          Severity: normal
          Priority: P
         Component: Headers
          Assignee: unassignedclangbugs at nondot.org
          Reporter: cerickson at curedev.com
                CC: craig.topper at gmail.com, llvm-bugs at lists.llvm.org,
                    richard-llvm at metafoo.co.uk

In the lzcntintrin.h, the 32-bit version of lzcnt should be named __lzcnt(),
not __lzcnt32().

This causes linker errors when compiling with ms compatibility because the
correct prototype is in intrin.h:

unsigned int __lzcnt(unsigned int);

See https://docs.microsoft.com/en-us/cpp/intrinsics/lzcnt16-lzcnt-lzcnt64 for

You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-bugs/attachments/20181213/4f01e21f/attachment-0001.html>

More information about the llvm-bugs mailing list