[llvm-bugs] [Bug 34964] New: LLVM repo signature is probably broken

via llvm-bugs llvm-bugs at lists.llvm.org
Mon Oct 16 06:11:24 PDT 2017


            Bug ID: 34964
           Summary: LLVM repo signature is probably broken
           Product: Packaging
           Version: unspecified
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: release blocker
          Priority: P
         Component: deb packages
          Assignee: unassignedbugs at nondot.org
          Reporter: mazay0 at gmail.com
                CC: llvm-bugs at lists.llvm.org

I tried to install clang on Debian Jessie following instructions from here:
But when I tried to do apt-get update I got the following error:

    W: Failed to fetch
 Hash Sum mismatch

    E: Some index files failed to download. They have been ignored, or old ones
used instead.

The issue is somehow connected with GPG key because if I remove the key

    apt-key del 15CF4D18AF4F7421

everything works fine (of course the  Warning about unsigned packages appears).

I added the key with the following command:

    wget -O - https://apt.llvm.org/llvm-snapshot.gpg.key|sudo apt-key add -

 Here is the output of "apt-key list":

    pub   4096R/AF4F7421 2013-03-11
    uid                  Sylvestre Ledru - Debian LLVM packages
<sylvestre at debian.org>
    sub   4096R/AF9463CE 2013-03-11

Bug reproduced on docker image debian:jessie

You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-bugs/attachments/20171016/3975a3ef/attachment.html>

More information about the llvm-bugs mailing list