[LLVMbugs] [Bug 18330] New: Compiling GNU Units hangs clang 3.4+

bugzilla-daemon at llvm.org bugzilla-daemon at llvm.org
Fri Dec 27 05:00:59 PST 2013


            Bug ID: 18330
           Summary: Compiling GNU Units hangs clang 3.4+
           Product: clang
           Version: trunk
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P
         Component: -New Bugs
          Assignee: unassignedclangbugs at nondot.org
          Reporter: cybjit at gmail.com
                CC: llvmbugs at cs.uiuc.edu
    Classification: Unclassified

Created attachment 11784
  --> http://llvm.org/bugs/attachment.cgi?id=11784&action=edit
reduced parse.tab.c

When compiling GNU Units 2.02 (http://www.gnu.org/software/units/) with clang
3.4 or 3.5, it hangs at parse.tab.c.
It was configured with CC=clang ./configure
It compiles and runs with clang 3.3.
I waited 15 minutes with 3.4 before giving up.

I am using clang 3.3, 3,4 and 3.5 from Ubuntu Trusty.
I also tried the Saucy packages from llvm.org/apt.

Turning off -O2 makes the compile succeeded.

I have tried to reduce a test-case.
clang -O -c units-clang-hang.c

You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-bugs/attachments/20131227/7f0410c5/attachment.html>

More information about the llvm-bugs mailing list