[LLVMbugs] [Bug 18194] Incorrect error when virtually inheriting from standard exception classes.

bugzilla-daemon at llvm.org bugzilla-daemon at llvm.org
Mon Dec 9 18:35:09 PST 2013


Natalie Wolfe <natalie at lifewanted.com> changed:

           What    |Removed                     |Added
             Status|RESOLVED                    |REOPENED
         Resolution|WORKSFORME                  |---

--- Comment #2 from Natalie Wolfe <natalie at lifewanted.com> ---
I just tried again with a completely clean install of Ubuntu 13.10 64-bit on a
VM and encountered the same error. I also had a 3rd party verify on their own
Ubuntu 13.10 machine, and he encountered the same errors (screenshot here:

I am installing Clang 3.4 from the saucy/universe repository
(https://launchpad.net/ubuntu/saucy/amd64/clang-3.4) using the command `sudo
apt-get install clang-3.4`. I am not adding any new repositories, this is just
from the Ubuntu 13.10 default repositories. Here are complete reproduction

 1) Start an Ubuntu 13.10 machine.
 2) Run `sudo apt-get install build-essential clang-3.4`
 3) Assert that `clang++ --version` reports version 3.4.
 4) Download the code attached to this ticket.
 5) Run `clang++ -std=c++11 -c /path/to/clangClass.cpp`
 6) Observe errors.

If you need simpler instructions I can send you the VM I tested with which has
steps 1-4 completed. Please let me know if I need to clarify anything, thank

You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-bugs/attachments/20131210/a447b336/attachment.html>

More information about the llvm-bugs mailing list