[LLVMbugs] [Bug 9826] New: [MC] Should use symbolic register names in the .cfi_* directives

bugzilla-daemon at llvm.org bugzilla-daemon at llvm.org
Mon May 2 07:16:18 PDT 2011


http://llvm.org/bugs/show_bug.cgi?id=9826

           Summary: [MC] Should use symbolic register names in the .cfi_*
                    directives
           Product: libraries
           Version: trunk
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P
         Component: Common Code Generator Code
        AssignedTo: unassignedbugs at nondot.org
        ReportedBy: rafael.espindola at gmail.com
                CC: llvmbugs at cs.uiuc.edu


Instead of printing:

f:
    .cfi_startproc
    .cfi_offset 6, -16
    .cfi_endproc

We could print

f:
    .cfi_startproc
    .cfi_offset %rbp, -16
    .cfi_endproc

Both produce bit identical results, but the second one is more readable. In the
interest of efficiency, the MCStreamer should probably stay the same: It is
given a register dwarf num. This means we need a dwarf num -> name mapping. We
can probably tblgen one.

-- 
Configure bugmail: http://llvm.org/bugs/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.



More information about the llvm-bugs mailing list