[LLVMbugs] [Bug 8124] copy is only important at the start of a method name
bugzilla-daemon at llvm.org
bugzilla-daemon at llvm.org
Thu Sep 9 18:08:19 PDT 2010
http://llvm.org/bugs/show_bug.cgi?id=8124
Ted Kremenek <kremenek at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |RESOLVED
Resolution| |INVALID
--- Comment #2 from Ted Kremenek <kremenek at apple.com> 2010-09-09 20:08:19 CDT ---
Confirmed. From the Cocoa naming conventions:
"You take ownership of an object if you create it using a method whose name
begins with “alloc” or “new” or contains “copy” (for example,alloc, newObject,
or mutableCopy), or if you send it a retain message."
Official guidelines here:
http://developer.apple.com/library/mac/#documentation/Cocoa/Conceptual/MemoryMgmt/Articles/mmRules.html%23//apple_ref/doc/uid/20000994-BAJHFBGH
--
Configure bugmail: http://llvm.org/bugs/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
More information about the llvm-bugs
mailing list