[lldb-dev] lldb_private::RegisterContext vs lldb_private::RegisterInfoInterface

Tatyana Krasnukha via lldb-dev lldb-dev at lists.llvm.org
Wed Sep 13 05:40:38 PDT 2017

Hi Ramana,

Looks like just a naming issue - classes derived from RegisterInfoInterface should be named as RegisterInfo<OS>_<Arch>, because they just implement a common interface to access targets's register info structures. Whereas RegisterContext relates to certain execution context and concrete frame, and implements process-specific functions, for example restoring registers state after expression evaluation.

Please, correct me anyone, if I'm wrong.


-----Original Message-----
From: lldb-dev [mailto:lldb-dev-bounces at lists.llvm.org] On Behalf Of Ramana via lldb-dev
Sent: Wednesday, 13 September, 2017 9:00 AM
To: lldb-dev at lists.llvm.org
Subject: [lldb-dev] lldb_private::RegisterContext vs lldb_private::RegisterInfoInterface


When deriving RegisterContext<OS>_<Arch>, why some platforms (Arch+OS) are deriving it from lldb_private::RegisterContext while others are deriving from lldb_private::RegisterInfoInterface or in other words how to decide on the base class to derive from between those two and what are the implications?

lldb-dev mailing list
lldb-dev at lists.llvm.org

More information about the lldb-dev mailing list