[lldb-dev] [Bug 31214] New: Don't stop on line 0

via lldb-dev lldb-dev at lists.llvm.org
Wed Nov 30 08:36:11 PST 2016


            Bug ID: 31214
           Summary: Don't stop on line 0
           Product: lldb
           Version: unspecified
          Hardware: PC
                OS: Windows NT
            Status: NEW
          Severity: normal
          Priority: P
         Component: All Bugs
          Assignee: lldb-dev at lists.llvm.org
          Reporter: paul_robinson at playstation.sony.com
                CC: llvm-bugs at lists.llvm.org
    Classification: Unclassified

Yesterday I tried committing LLVM r288212, which introduced a number of
line-table records with line number 0.  The DWARF spec says this means
there is no particular source location associated with those instructions.

I was expecting LLDB to ignore line-0 records, but apparently it does not.
reported 3 test failures:

FAIL: TestExitDuringStep.ExitDuringStepTestCase.test_dwarf
FAIL: TestExitDuringStep.ExitDuringStepTestCase.test_dwo
FAIL: TestExitDuringStep.ExitDuringStepTestCase.test_gmodules

And looking at the traces, it seems that there was a single-step expecting
to stop on line 30 but found itself stopped on line 0.

I thought I had tried this with LLDB before, but apparently I didn't
follow the website instructions correctly.  (I'm still seeing more
failures and other funny stuff than I expected, but if I apply or
remove my patch it's still the same 3 tests that get different results,
so I'm not going to worry about it.)

LLDB should not stop on an instruction associated with line 0.
It should proceed to the next instruction with a non-zero line number.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/lldb-dev/attachments/20161130/aa3e4288/attachment.html>

More information about the lldb-dev mailing list