[Lldb-commits] [PATCH] D150236: Thread::GetStackFrameCount should forestall interruption
Jonas Devlieghere via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Thu May 11 04:16:17 PDT 2023
JDevlieghere added inline comments.
================
Comment at: lldb/include/lldb/Target/StackFrameList.h:106
+ /// Returns true if the function was interrupted, false otherwise.
+ bool GetFramesUpTo(uint32_t end_idx, bool allow_interrupt = true);
----------------
I personally would prefer to have an `InterruptPolicy` (e.g. `AllowInterrupt`, `DenyInterrupt`) to limit the proliferation of boolean flags and improve readability.
================
Comment at: lldb/source/Target/StackFrameList.cpp:512-513
+ if (allow_interrupt && dbg.InterruptRequested()) {
+ Log *log = GetLog(LLDBLog::Host);
+ LLDB_LOG(log, "Interrupted %s", __FUNCTION__);
+ was_interrupted = true;
----------------
Nit: you could inline his and still fit in a single line (probably).
Long term I think we should have an API in `Debugger` that allows you to report who was interrupted and then we can centralize this logging + have a way for the API tests to request that info (rather than having to parse the logs).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D150236/new/
https://reviews.llvm.org/D150236
More information about the lldb-commits
mailing list