[Lldb-commits] [PATCH] D146679: [lldb] Add support for the DW_AT_trampoline attribute with mangled names

Augusto Noronha via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Thu Mar 23 11:49:10 PDT 2023


augusto2112 added inline comments.


================
Comment at: lldb/include/lldb/Target/Target.h:253
 
+  bool GetEnableTrampolineSupport() const;
+
----------------
JDevlieghere wrote:
> What does trampoline "support" mean? Could this be named something more descriptive? From the description of the patch it sounds like this guards whether you step through trampolines, so maybe something like `GetEnableStepThroughTrampolines` or something? 
Yeah I agree the name is pretty generic. This guards both stepping and setting breakpoints on trampolines (by name). We could potentially have two different settings (one for stepping on trampolines, one for breakpoints), but at the same time I don't think there are many users who would want to change only of or the other. I'll add a doxygen comment here with the explanation of what this does, but I'd be happy to change the setting name if anyone has a better suggestion.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D146679/new/

https://reviews.llvm.org/D146679



More information about the lldb-commits mailing list